Power Profile MetaMotion R

Hi,

I am trying to analyse the power profile of a meta motion r using a Monsoon power monitor.
The problem is that if I provide 3.7V to the +bat pin through the power monitor the device does not start.
It starts only if I connect a USB cable while the +bat pin is still connected and powered by the power monitor. In this configuration however the power monitor does not show any current profile.
As soon as I unplug the USB the device stops so I cannot see the power profile.
I have an SD card attached to it.

Any idea?

Thanks!

Comments

  • @alessandromontanari

    How do you have the power monitor attached to the MMR board?  Our R series boards have no problem operating from an external power supply across +Bat.

    If the board is functioning with the USB connected, this is likely supplying more current than the monitor source is capable of.  That or the internal impedance of the monitor is causing issues.

    Is the SD card attached to the MMR board?  SD cards can consume upwards of 100mA in some of their modes and may be the source of an issue.
  • Hi Matt,

    I am attaching the output of the power monitor directly to +Bat and Gnd on the metamotion. The SD card is attached but I don't think the supplied current is a problem given that the power monitor is capable of providing 3A. Also, in the past I did the same with the metawear R, with an SD card attached and I didn't have any problems.

    I forgot to mention that I am running a custom firmware. Maybe I need to enable the brown-out detection or something similar?

    Thanks 
  • @alessandromontanari

    There should not be a problem with how you've connected the monitor.

    The 3V supply is regulated down from the 3.0-4.2V of the battery source, so any current demands on the 3V supply would be limited by that regulator.

    Can you check the +Bat input and 3V rail with a multimeter or scope?
  • Hi Matt,

    when I set the power monitor to 3.7V I get 3.7V on +Bat, 3V on the 3V rail and 1.25V on the Vusb pin. The current I see on the monitor is constant at about 9mA.

    I also noticed that if I short the +Bat with the Vusb the device boots correctly and I see the power profile on the monitor. 
    Isn't this strange?

    Thanks
  • @alessandromontanari

    Have you tried feeding 3.7V from a lab power supply or similar?  The boards are normally operated from only a battery at 3.0-4.2V and there are no issues.  Vusb is designed to be floated when not charging so it should not be a problem.  Is the device running the factory firmware?
  • I tried also from a lab power supply and it's the same.
    I am using a custom firmware but I will try with another board that has the stock firmware on it.
    Maybe I need to enable something in the firmware?

    Thanks
  • With the stock firmware it works fine, when I apply power to +bat the board boots correctly.
    What could cause this problem in my firmware?
    Once it started it works fine.
  • @alessandromontanari

    The battery charger seems to be misbehaving in some way.  It could be how your pins which interface the charger are configured.

    The 5V sense pin should only be set as an input.  Setting it as output high may pull the charger input voltage high enough for it to misbehave.

    The charge status input should be used as input with a pull up resistance.  You may also need to be careful with this pin if you use the pin change notification hardware of the nRF SDK.  In some cases -- namely operating off USB without a battery -- the charger switches on and off fast enough (kHz+) to bog down the SoC handling the interrupts.  It definitely causes resets on the nRF51, and possibly the nRF52.

    Also, there is a UICR register to turn the NFC pins into GPIO pins you may want to look at, there could be a negative interaction if it isn't configured -- I don't recall off the top of my head which pins it affects.
Sign In or Register to comment.