Not getting data from Accelero/Gyro, Have to do hard reset

We are experience problem with Meta RG board where we are not getting data from accelero/gyro on metawear app. We have to do hard reset and connect again.

Is their any firmware update available to fix this issue.

Comments

  • edited July 24
    What device and OS are you using the MetaWear board with?  How long does it take until this issue occurs?

    Try using the MetaBase app to stream data instead.
  • Issue is sporadic. We are building our own custom app so getting this issue on that app as well as metawear.
    We are using Android app and Metawear RG board.
    With metabase, it is not even able to connect. Here are details.

    1. Metawear - Able to connect but not getting data from accelero/Gyro.
    2. Metabase - Not able to connect.
    3. Tried after resetting from hard reset button but still not working.
    4. Shot the debug ports (first with last) and then it worked fine with both the apps.
  • The button does not reset the board unless you program it to.  Otherwise, it's just a button.

    • What Android device and OS are you using?
    • Has MetaBase been working fine after you shorted the pins?
    • Post the MetaWear code you are currently running in your app.
  • Hi, Sorry for late response.

    -> We tried it on different devices with different versions of android OS. But it failed on all.
    -> Yes, MetaBase and Metawear worked fine after shorting the pins.
    -> We used metawear app downloaded from playstore.

    This seems to be an issue with firmware. Now I am getting issue with MetamotionR as well. Acceleremeter and Gyro stops after few seconds. Tried it with Metawear app as well. I have not shortened the pins to test it further. Let me know how we can connect to debug this issue.


  • The MetaBase app is designed specifically for collecting data.  Stick with that app if that is what you want to do with your boards.  

    What android devices and OS specifically are you testing with?
  • We are using our own app and I cannot share the code of that here. Only when we get some issue with Board is when we test it with metabase and metawear. We are using 3 boards and got issue with 2 of these. We have ordered another 5 which we will be testing with our app.

    Android devices - Samsung (Lollypop - 5.1.1), Moto (Marshmallow)



  • Which Samsung and Moto models?

    Your previous post stated MetaBase worked fine, but now you just said MetaBase is not working?

    What settings are you configuring the sensors with?
  • When I said "Metabase worked" it was an answer to question whether it worked after hard reset. Please read the full thread.

    models: MotoG4, Samsung Galaxy G2

    //configuring Accelerometer//
       Accelerometer.ConfigEditor<?> editor = accelerometer.configure();
       editor.odr(100f);
       editor.range(16f);
       editor.commit();

    //configuring Gyrometer//
            gyro.configure()
            .odr(GyroBmi160.OutputDataRate.ODR_100_HZ)
            .range(GyroBmi160.Range.FSR_2000)
            .commit();

    //starting Accelerometer and gyrometer//
         accelerometer.packedAcceleration().start();
         accelerometer.start();
        gyro.packedAngularVelocity().start();
        gyro.start();


  • I know the boards work after a hard reset.  My question is to see if the MetaBase app works without the same issues from the MetaWear app.  If the board is in a bugged state after using the MetaWear app, it won't work with MetaBase so of course it makes sense to check after the hard reset.

    You should also configure the connection parameters as outlined in the documentation:

    We have not had good Bluetooth experiences with MotoG devices.  We have a Galaxy S4 and S4 mini (released around the same time as the G2) and those work fine as well.  The best experiences we've had so far is with the newer Nexus devices (5, 6, 9) running Android M.
Sign In or Register to comment.